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Introduction to the SketchUp User Interface  
SketchUp is designed to be simple and easy to use. The main parts of the SketchUp interface are the Title 
bar, menus, toolbars and tool palettes, drawing area, Status bar, and the Measurements toolbar. The 
following images show the SketchUp user interface. 
Windows  

 
 
Mac OS X  

 
 
Title Bar 
The title bar, at the top of SketchUp, contains the standard window controls (close, minimize, and 
maximize), the name of the currently opened file, and a title bar collapse/expand button on the right (Mac 
only). A blank drawing area appears when you start SketchUp and the name of the currently opened file is 
"Untitled" in the title bar, indicating that you have not yet saved your work. 
 
Menus  
Menus appear below the title bar on a Windows machine and at the top of your screen on a Mac. The 
majority of SketchUp tools, commands, and settings are available within these menus. The menus are: 
SketchUp (Mac only), File, Edit, View, Camera, Draw, Tools, Window, and Help.  
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Toolbars  
The toolbars, appearing below the menus and along the left side of the Windows application, contain a 
user-defined set of tools and controls. By default, the toolbar contains the basic set of SketchUp tools, 
referred to as the getting started tools. Additional toolbars can be displayed by selecting the toolbars under 
the View > Toolbars menu item. 
 
Drawing Area  
The drawing area is where you create your model. The 3D space of the drawing area is identified visually 
by the drawing axes. The drawing axes are three colored lines, perpendicular to each other. These axes are 
helpful in providing a sense of direction in 3D space while you work. 
The drawing area also contains a simple model of a person to give you a sense of 3D space. 
 
Status Bar  
The status bar is the long gray rectangular area at the bottom of the drawing area. 
 
Windows 

 
 
Mac  

 
 
The left side of the status bar contains buttons to geo-locate, claim credit, and sign in, respectively. The 
middle area contains a button to show the instructor and displays tips for the currently used drawing tools, 
including special functions accessible using keyboard shortcuts. Watch the status bar to discover advanced 
capabilities of each of the SketchUp tools. 
 
The Measurements Toolbar, located on the right side of the status bar, displays dimensional information 
while you draw. You can also enter values into the Measurements Toolbar to manipulate currently selected 
entities, such as creating a line of a specific length. 
 
To the right of the Measurements Toolbar is the window resize handle which is used to change the size of 
the application window and drawing area. You can also make the window larger so you can see the entire 
message in the status bar. 
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Using the Mouse in SketchUp  
SketchUp can work with both 3-button and 1 button (commonly found on Mac computers) mice. A 3-
button mouse is preferred as it will greatly increase your efficiency with SketchUp. You must learn 
different mouse operations before you can begin drawing in SketchUp. 
 
Using a 3-Button Mouse  
A three-button mouse consists of a left mouse button, a middle-mouse button (also called the scroll wheel) 
and a right-mouse button. The following is an overview of the different mouse operations commonly 
performed in SketchUp with a three-button mouse: 

• Click - A click refers to the user quickly pressing the releasing the left-mouse button. 
• Click and hold - A click and hold refers to the user pressing and holding down the left-mouse 

button. 
• Click, hold, drag - A click, hold, drag operation refers to the user pressing and holding down the 

left-mouse button and then moving the cursor. 
• Middle click, hold, drag - A middle click, hold, drag operation refers to the user pressing and 

holding down the middle-mouse button and them moving the cursor. 
• Scroll - A scroll refers to a user spinning the middle mouse wheel. 
• Context-click - A context-click refers to pressing and holding the right-mouse button. Context-

clicks are usually used to display context menus. Context menus are menus whose contents vary 
depending on the context in which they are invoked (usually on one or more entities in the 
drawing area or within a component, such as a dialog box). The following image shows a context 
menu for a Face entity. 

 
Using a 1-Button Mouse  
The following is an overview of the different mouse operations commonly performed in SketchUp with a 
one-button mouse: 

• Click - A click refers to the user quickly pressing the releasing the mouse button. 
• Click and hold - A click and hold refers to the user pressing and holding down the mouse button. 
• Click, hold, drag - A click, hold, drag operation refers to the user pressing and holding down the 

mouse button and then moving the cursor. 
• Scroll - A scroll refers to a user spinning the mouse ball (found on some Mac computers). 
• Context-click - A context-click refers to pressing and holding the control key while simultanously 

pressing clicking the mouse button. Context-clicks are usually used to display context menus. 
Context menus are menus whose contents vary depending on the context in which they are 
invoked (usually on one or more entities in the drawing area or within a component, such as a 
dialog box). 
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Working in 3D  
Creating models in SketchUp primarily consists of two operations: 

• Viewing models in 3D space using the camera tools (rotate, zoom in, zoom, out, and pan). 
• Creating 2D faces or shapes and transforming 2D faces, using the Push/Pull Tool, into a 3D 

geometry. 
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Viewing a Model in 3D Space  
SketchUp implements the concept of a camera to represent your point of view of the model. Simply, you 
(the user) are treated as though you were a camera looking at your model as you work. 
There are several tools in SketchUp for viewing your model in 3D space. The most commonly used camera 
tools are the Orbit tool, Pan tool, Zoom tool, and Zoom extents tool. 
 
Preparing to Use the Viewing Tools  
You must have a model in the drawing area before we can practice viewing. By default, SketchUp contains 
a model of a person at the origin of the axes. You can use that model for the purposes of these exercises. 
Or, follow these steps to place one of SketchUp's pre-built models into the drawing area: 

1. Click on Window > Components. The Component Browser is displayed. 

2. Click on the 'Collections and Searches' drop-down list identified by a downward arrow ( ). 
3. Click on the Architecture item. Architectural collections are listed. 
4. Click on one of the collections, such as "Furniture." The 3D Warehouse appears. 
5. Click on one of the collections, such as "Beds." Several components appear. 
6. Click on one of the pre-built architectural models, such as a "Twin size bunk bed." The Twin size 

bunk bed page appears. 
7. Click on the Download Model button. The Load into Model? dialog box appears. 
8. Click on the Yes button. The model appears in SketchUp attached to the Select tool. 
9. Click anywhere in the drawing area to place the model. The model will be positioned in the 

drawing area. 
 
Using the Orbit Tool  
Use the Orbit Tool to rotate the camera about the model and is often used while drawing to quickly change 
your view in between drawing operations. Activate the Orbit Tool from either the Camera Toolbar or the 
Camera menu. To orbit your model: 

1. Click on the Orbit Tool (  ) in the toolbar. The cursor changes to two interconnected 
perpendicular ovals (  ). 

2. Click anywhere in the drawing area. 
3. Move your cursor in any direction to rotate around the center of the drawing area. 

 
Using the Orbit Tool (3-Button Mouse)  
A 3-button mouse allows you to orbit a model without exiting the current drawing tool, speeding up your 
drawing. To orbit with a 3-button mouse: 

1. Click on the Pencil Tool ( ) in the toolbar. The cursor changes to a pencil ( ). 

2. Click and hold the middle-mouse button. The cursor changes to the Orbit Tool cursor (  ). 
3. Move your cursor in any direction to rotate around the center of the drawing area (continue to 

keep your finger pressed on the middle mouse button). 

4. Release the middle-mouse button to return to the Pencil Tool ( ). The cursor changes back to a 
pencil ( ). 

 
Using the Pan Tool  
Use the Pan Tool to move the camera (your view) vertically and horizontally. Activate the Pan Tool from 
either the Camera Toolbar or the Camera menu. To pan using the Pan Tool: 

1. Click on the Pan Tool ( ). The cursor changes to a hand ( ). 
2. Click anywhere in the drawing area. 
3. Move the cursor in any direction to pan. 

 
Using the Pan Tool (3-Button Mouse)  
A 3-button mouse allows you to pan your view without exiting the current drawing tool, speeding up your 
drawing. To orbit with a 3-button mouse: 
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1. Click on the Pencil Tool ( ) in the toolbar. The cursor changes to a pencil ( ). 
2. Press and hold the Shift key. 

3. Press and hold the middle-mouse button. The cursor changes to the Pan Tool cursor ( ). 
4. (optionally) Press and hold the left mouse button while pressing and holding the middle mouse 

button (scroll wheel) to activate the Pan Tool. 
 
Using the Zoom Tool  
Use the Zoom Tool to move the camera (your view) in or out. Activate the Zoom Tool from either the 
Camera Toolbar or the Camera menu. 

1. Click on the Zoom Tool ( ) in the toolbar. The cursor changes to a magnifying glass ( ). 
2. Click and hold anywhere in the drawing area. 
3. Drag the cursor up to zoom in (closer to the model) and down to zoom out (farther from the 

model). 
 
Using the Zoom Tool (3-Button Mouse)  
A 3-button mouse allows you to zoom in or out without exiting the current drawing tool, speeding up your 
drawing. To zoom with a 3-button mouse: 

1. Click on the Pencil Tool ( ) in the toolbar. The cursor changes to a pencil ( ). 
2. Roll the scroll wheel (middle-mouse button) forward to zoom in on your model. 
3. Roll the scroll wheel (middle-mouse button) back to zoom out from your model. 

 
Using the Zoom Extents Tool  
Use the Zoom Extents Tool to zoom your view to a distance where the whole model is visible and centered 
in the drawing area. Activate the Zoom Extents Tool from either the Camera Toolbar or the Camera menu. 
The Zoom Extents Tool is often used when your model goes off screen or you find yourself confused about 
the view of your model. Click on the Zoom Extents Tool ( ) in the toolbar. Your model is centered in the 
drawing area. 
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Creating Geometry with the Push/Pull Tool  
Use the Push/Pull Tool to push and pull faces to add volume to or subtract volume from your models. You 
can use push/pull to create volume out of any face type, including circular, rectangular, and abstract faces. 
Activate the Push/Pull Tool from either the Toolbar or the Tools menu. 
 
Preparing to Use the Push/Pull Tool  
Start a new file before continuing with the next exercise. To start a new file: 

1. Select File > New. A dialog box is displayed asking if you want to save your changes. 
2. Click on the No button. A new, blank, drawing area appears. 

3. Click on the Rectangle Tool ( ). The cursor changes to a pencil with a rectangle ( ). 
4. Click anywhere in the drawing area to set the first corner point of the rectangle. 
5. Move the cursor diagonally. A rectangle will expand out from the first corner point. 

 
6. Click again to set the second corner of the rectangle. A rectangular face is created bordered by 

four edges. 

 
 
Using the Push/Pull Tool  
To push or pull a face: 

1. Click on the Push/Pull Tool ( ). The cursor will change to a 3D rectangle with an up arrow (
). 

2. Click on the rectangular face created in the previous exercise. 

 
3. Move the cursor to create (or decrease) volume. 
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Press the Esc key at any point during the operation to start over. 

4. Click when the volume has reached the desired size. 
You can also press and hold the mouse button, drag the mouse, and release the mouse button to 
create a volume. 

 
You can use the Push/Pull Tool to create volume from any shape, whether it be an abstract shape drawn 
using the Freehand Tool or a shape drawn on another piece of 3D geometry. Following are some examples 
of Push/Pull operations. 
 
Pushing and Pulling a Curved Face  
You can use the Push/Pull Tool on faces that have an arc as an edge similarly to using the Push/Pull Tool 
on regular faces. The curved face that results from the push/pull operation is called a Surface entity. 
Surfaces can be adjusted as a whole, but are comprised of a number of faces or a curved face set. 

 
 
Creating Voids with Push/Pull  
You can create a void, or empty space, simply by drawing a 2D shape on 3D geometry and using the 
Push/Pull Tool to push the 2D face until it meets the back face of the 3D geometry. The following three 
images demonstrate how to push/pull a 2D face that is drawn on 3D geometry to create a void. 
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Drawing Shapes with the Circle, Arc, and Rectangle Tools  
The majority of drawing tools in SketchUp, such as the Circle, Arc, and Rectangle Tool, are designed to 
speed up what can be drawn using the Pencil Tool. 
 
Drawing Circles  
Use the Circle Tool to draw circle entities. Activate the Circle Tool from the Toolbar or the Draw menu. To 
draw a circle:  

1. Select the Circle Tool ( ). The cursor changes to a pencil with a circle. 
2. Click to place the center point of the circle. 
3. Move the cursor out from the center point to define the radius of your circle. As you move the 

cursor, the radius value is displayed dynamically in the Measurements Toolbar and can be 
specified by typing in a length value followed by pressing the Enter (Microsoft Windows) or 
Return (Mac OS X) key. You can also specify the segmentation for the circle in the 
Measurements Toolbar. 

 
Press the Esc key at any point during the operation to start over. 

4. Click to finish the circle. 
Tip: You can also click and hold the mouse button to set the center of the circle, and drag outward 
without releasing the button to set the radius. Release the mouse button to complete the circle. 

 
Drawing Arcs  
Use the Arc Tool to draw Arc entities, comprised of multiple line segments (which can be edited as a single 
arc). Activate the Arc Tool from the Toolbar or from the Draw menu. 
Arc entities consist of three parts: the starting point, the ending point and the bulge distance. The distance 
between the starting point and the ending point is also known as the chord length. To draw an arc: 

1. Select the Arc Tool ( ). The cursor changes to a pencil with an arc. 
2. Click to place the starting point of your arc. 
3. Move the cursor to the ending point of your chord. 
4. Click to place the ending point of your arc. A straight line is created. 
5. Move your cursor perpendicular to the straight line to adjust the bulge distance. A straight line will 

extend perpendicular from the straight line. 

 
Note: Press the "Esc" key at any point during the operation to start over. 

6. Click to set the bulge distance. 
 
Drawing Rectangles  
Use the Rectangle Tool to draw rectangular Face entities, specified by clicking at two opposite corners of 
the desired shape. Activate the Rectangle Tool from either the Toolbar or Draw menu. 
Rectangles can be placed on existing faces or separate from existing geometry (aligned to an axes plane). 
To draw a rectangle: 

1. Select the Rectangle Tool ( ). The cursor changes to a pencil with a rectangle. 
2. Click to set the first corner point of the rectangle. 
3. Move the cursor diagonally. 

Note: Press the Esc key at any point during the operation to start over. 
4. Click again to set the second corner point of the rectangle. 
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Creating your first model  
It will take some time to master SketchUp as with any new software. However, following is a project to 
help you better learn the tools and concepts covered in this document. 
 
Creating a chair in SketchUp: The subtractive approach  
You will create a chair by subtracting volume from a 3D form in this exercise. This exercise is 
accomplished by creating the profile of a chair on a 3D form and then using the Push/Pull tool to remove 
the pieces of the form that will not be in the final model. To crate a chair using a subtractive approach: 

1. Select the Rectangle tool ( ). 
2. Click to set the first corner point of the rectangle. 
3. Move the cursor diagonally. 
4. Type 18,18 and press the Enter (Microsoft Windows) or Return (Mac OS X) key. Your 

dimensions appear in the Measurements toolbar and the rectangle will snap to 18 by 18 inches. 
 

 

 
5. Zoom, orbit, and pan to such that your rectangle is large enough to push/pull with the Push/Pull 

tool. Refer to Viewing a Model in 3D Space for further information.  

 
6. Select the Push/Pull tool ( ). 
7. Click on the rectangular face. 
8. Move the cursor to create (or decrease) volume. 
9. Type 4' and press the Enter (Microsoft Windows) or Return (Mac OS X) key. Your dimensions 

appear in the Measurements toolbar and the rectangle will expand up and snap to 4 feet. 
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10. Select the Line tool ( ). 
11. Draw a line from a top, horizontal, edge, (vertically) about half-way down your model. 

 
12. Draw a line from the ending point of the last line horizontally until you meet a vertical edge. 
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13. Select the Rectangle tool ( ). 
14. Draw a rectangle to represent the space between the legs of the chair. The profile of a chair is now 

drawn on one side of your model. 

 
15. Select the Push/Pull tool ( ). 
16. Click on the rectangular face you just drew between the legs. 

 
17. Push the rectangular face until it meets the back of the model. The tool tip should say 'on face' 

when the cursor has met the back face of the model.  
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18. Click to remove the area below the seat of your chair. The area below the seat of your chair should 

disappear. 

 
19. Remove the area above the seat and against the back by repeating the process you just used to 

remove the area below the seat. You're model should now closely resemble a 3D chair (without 
individual legs). 
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20. Zoom, orbit, and pan under the chair so that you are facing the back legs. 

 
21. Use the Rectangle tool to draw a rectangle that represents the space between the two back legs.  

 
22. Use the Push/Pull tool to remove the area between the back legs. 

 
23. Repeat the three previous steps with the front legs. 
24. Draw an arc across the top of the back starting just below the left side of the back of the chair. A 

separate face will be created at each corner of the top of the chair. 
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25. Use the Push/Pull tool to remove the two areas at the top of the chair and create a rounded chair 
back. 

      
26. Zoom, orbit, and pan to such that you can view the chair in its normal, upright, position. Refer to 

Viewing a Model in 3D Space for further information. 
 
Creating a chair in SketchUp: The additive approach 
You will create a chair by starting with a chair seat and adding the legs and back. To create a chair using a 
additive approach: 

1. Select the Rectangle tool ( ). 
2. Click to set the first corner point of the rectangle. 
3. Move the cursor diagonally. 
4. Type 18,18 and press the Enter (Microsoft Windows) or Return (Mac OS X) key. Your 

dimensions appear in the Measurements toolbar and the rectangle will snap to 18 by 18 inches. 
You are creating a chair seat. 

 
 

 
5. Zoom, orbit, and pan to such that your rectangle is large enough to push/pull with the Push/Pull 

tool. Refer to Viewing a Model in 3D Space for further information.  

 
6. Select the Push/Pull tool ( ). 
7. Click on the rectangular face. 
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8. Move the cursor to create the seat thickness. 

 
9. Draw a line toward the back of the seat to represent the profile of the seat back. 

 
10. Use the Push/Pull tool on this rectangle to create the seat back. 

 
11. Draw an arc across the top of the back starting just below the left side of the back of the chair. 

Two separate faces will be created at each corner of the top of the chair. 

 
12. Use the Push/Pull tool to remove the two areas at the top of the chair and create a rounded chair 

back. 
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13. Zoom, orbit, and pan to such that you can view the bottom of the chair seat. Refer to Viewing a 

Model in 3D Space for further information.  
14. Select the Tape Measure tool ( ). 
15. Click on one edge of the chair bottom. 
16. Move the cursor to away from the edge. A guide line will be drawn perpendicular to the line. 

Guide lines help you draw geometry to a specific dimension. 

 
17. Type 2 and press the Enter (Microsoft Windows) or Return (Mac OS X)key. Your dimensions 

appear in the Measurements toolbar and a guide will be created 2" away from the edge. 
18. Repeat steps 15-17 to create three more guides. Your model should look like the following: 

 
19. Use the Rectangle tool to create the profiles of each chair leg within each corner of the chair 

bottom. The Rectangle tool will snap to each guide in the corner to make accurate 2" x 2" legs. 
The following picture shows the resulting four rectangular faces in each corner of the chair 
bottom. 
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20. Use the Push/Pull tool to create the legs from the four faces created in the previous step. You can 
use inference to align length of the second through fourth leg to the length of the first leg. 

      
21. Use the Eraser tool to erase all of your guide lines. 
22. Zoom, orbit, and pan to such that you can view the chair in its normal, upright, position. Refer to 

Viewing a Model in 3D Space for further information. 
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Next steps  
All of the principles used in creating the chair are also used to creating models of houses, people, cars, and 
anything else in SketchUp. For Further Help: 

• Watch Video Tutorials: http://sketchup.google.com/intl/en/training/videos.html 
• Read the User's Guide (http://support.google.com/sketchup/bin/answer.py?answer=116174) and 

Reference Guide (http://support.google.com/sketchup/bin/answer.py?answer=116008). 
• Participate in the Google SketchUp Help Forum 

(https://groups.google.com/a/googleproductforums.com/forum/#!forum/sketchup) 
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